Aircrack-ng forum

Please login or register.

Login with username, password and session length
Advanced search  


Aircrack-ng 1.7 release

Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Message icon:

(Clear Attachment)
(more attachments)
Restrictions: maximum individual size 10240KB
Note that any files attached will not be displayed until approved by a moderator.
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Which Aircrack-ng program replays traffic? Lowercase:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: kcdtv
« on: July 31, 2016, 04:06:32 am »

It does(I believe on other systems).
I am not so sure but anyway, that would be without injection so you will be just able to use airodump-ng to sniff the traffic.
It is not very interisitng for you to get it works as it would be so limited
Posted by: melvin1888
« on: July 29, 2016, 02:41:10 pm »


Compiled Aircrack-ng 1.2 rc4

Ran airmon-ng and it reported the correct chipset, thought I was on to a winner.

Still can't get it into monitor mode.
Tried to do it manually (ie ifconfig wlan1 down, then iwconfig wlan1 mode monitor) and get a 'Set Mode' error. Googled that and tried a suggestion on a formum, but still no luck.

I think I have to resign myself to the fact that this wireless adapter won't go into monitor mode on the Pi. It does(I believe on other systems).

Thanks for trying to help.
Posted by: misterx
« on: July 26, 2016, 11:59:13 pm »

One thing I didn't notice, you have a very old version, you might want to remove that and build from sources.

Try that first and report back.
Posted by: melvin1888
« on: July 26, 2016, 08:02:35 pm »


Sorry, was away for a few days.

Strangely, dmesg isn't logging anything. Could it be logged somewhere else on the PI?

Posted by: misterx
« on: July 20, 2016, 12:03:12 am »

Just FYI, you're one version behind.

Could you attach (not paste) dmesg, it might give a clue on what happened to wlan1.
Posted by: melvin1888
« on: July 19, 2016, 08:38:39 am »


wlan0     IEEE 802.11bgn  ESSID:"LBS Wifi"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 0A:18:D6:6D:E6:AE
          Bit Rate=52 Mb/s   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=50/70  Signal level=-60 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

wlan1     unassociated  Nickname:"rtl_wifi"
          Mode:Managed  Access Point: Not-Associated   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

$sudo airmon-ng

Interface       Chipset         Driver

wlan0           Unknown         brcmfmac_sdio - [phy0]
wlan1           Unknown                 r8712u

$sudo airmon-ng start wlan1
Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID     Name
421     wpa_supplicant
448     avahi-daemon
459     dhcpcd
469     avahi-daemon
1401    wpa_supplicant
Process with PID 421 (wpa_supplicant) is running on interface wlan0
Process with PID 1398 (wlan1) is running on interface wlan1
Process with PID 1401 (wpa_supplicant) is running on interface wlan1

Interface       Chipset         Driver

wlan0           Unknown         brcmfmac_sdio - [phy0]
wlan1           Unknown                 r8712u (monitor mode enabled)

$sudo airmon-ng check kill

$sudo airmon-ng start wlan1
Interface       Chipset         Driver

wlan0           Unknown         brcmfmac_sdio - [phy0]

The wlan1 adapter has disappeared. I suspect the kill process is the cause, but not sure what to do now.

Even though it says its in monitor mode, it doesn't give a device (usually mon0), and obviously my python script (using scapy) throws an exception soon as I try the sniff function.


PS Version - Aircrack-ng 1.2 beta3 - (C) 2006-2013 Thomas d'Otreppe
Posted by: misterx
« on: July 19, 2016, 12:46:36 am »

What is the exact output of airmon-ng?

What version of aircrack-ng are you running (check out the FAQ to know how to do it)?
Posted by: melvin1888
« on: July 18, 2016, 04:08:34 pm »


Trying to get a Realtek USB adapter into monitoring mode. Its a Raspberry Pi 3, so 'iwconfig' shows two adapters and so does 'airmon-ng' with no arguments (The onboard wireless adapter and the USB adpater, as expected). When I try 'airmon-ng start wlan1' it says its going into monitoring mode, but doesn't give me an interface (ie mon0 or anything). when I type 'iwconfig' again, nothing has changed, both adapters are still listed.
As per the wiki I issue 'airmon-ng check kill' to kill any processes, but then I only have the onboard wireless adapter available. The usb realtek disappears, and therefore I can't get it into monitor mode.

Any ideas?