Aircrack-ng

Please login or register.

Login with username, password and session length
Pages: 1 [2] 3 4 ... 10
 11 
 on: October 13, 2018, 08:03:03 AM 
Started by kimocoder - Last post by lewr
When installing, using ./dkms-install.sh, I get the error:

"Your kernel headers for kernel 4.17.0-kali1-amd64 cannot be found at
/lib/modules/4.17.0-kali1-amd64/build or /lib/modules/4.17.0-kali1-amd64/source."

Taking a look at /lib/modules/ the are two directories /4.17.0-kali1-amd64 and /4.18.0-kali1-amd64.
The /build and /source directories do not exist in the directory in /4.17.0-kali1-amd64 as suggested in the error code. However, in the /4.18.0-kali1-amd64 directory, they are present.

Out of curiosity, I tried copying /build and /source into /4.17.0-kali1-amd64 (using cp -r).
Now when running ./dkms-install.sh the installer runs and "completes", but as one would expect, this does not enable the driver to work with the hardware.

I have tried using several versions of the driver, including the latest one (v5.3.4).
It seems like others are having this issue as well, for example, https://github.com/aircrack-ng/rtl8812au/issues/218
Do you have any suggestions to fixes? Or is this something that you will be able to update/fix?



 12 
 on: October 13, 2018, 04:14:46 AM 
Started by Crackfox - Last post by Crackfox
Tks for getting back, I'll try the 1.4 version and see how I get on

 13 
 on: October 12, 2018, 05:31:10 PM 
Started by Crackfox - Last post by misterx
Use 1.4.

If you insist on 1.1, there should be an older commit that solved this issue and I think searching for openssl should help finding it.

 14 
 on: October 12, 2018, 01:12:17 PM 
Started by Crackfox - Last post by Crackfox
Hi all,

I'm a newbie here and have tried to install aircrack-ng on VM Linux, I'm getting the following error.
I've installed build-essential and libssl-dev(I'm doing this from a book I bought)

All advice gretly appreciated, tks

attacker@attacker-VirtualBox:~/aircrack-ng-1.1$ make
make -C src all
make[1]: Entering directory '/home/attacker/aircrack-ng-1.1/src'
make -C osdep
make[2]: Entering directory '/home/attacker/aircrack-ng-1.1/src/osdep'
Building for Linux
make[3]: Entering directory '/home/attacker/aircrack-ng-1.1/src/osdep'
make[3]: '.os.Linux' is up to date.
make[3]: Leaving directory '/home/attacker/aircrack-ng-1.1/src/osdep'
make[2]: Leaving directory '/home/attacker/aircrack-ng-1.1/src/osdep'
gcc -g -W -Wall -O3 -D_FILE_OFFSET_BITS=64 -D_REVISION=0  -Iinclude   -c -o crypto.o crypto.c
crypto.c: In function ‘calc_mic’:
crypto.c:276:11: error: storage size of ‘ctx’ isn’t known
  HMAC_CTX ctx;
           ^~~
crypto.c:302:2: warning: implicit declaration of function ‘HMAC_CTX_init’; did you mean ‘HMAC_CTX_new’? [-Wimplicit-function-declaration]
  HMAC_CTX_init(&ctx);
  ^~~~~~~~~~~~~
  HMAC_CTX_new
crypto.c:312:2: warning: implicit declaration of function ‘HMAC_CTX_cleanup’; did you mean ‘HMAC_CTX_get_md’? [-Wimplicit-function-declaration]
  HMAC_CTX_cleanup(&ctx);
  ^~~~~~~~~~~~~~~~
  HMAC_CTX_get_md
crypto.c:276:11: warning: unused variable ‘ctx’ [-Wunused-variable]
  HMAC_CTX ctx;
           ^~~
crypto.c: In function ‘calc_tkip_mic_key’:
crypto.c:885:5: warning: this ‘if’ clause does not guard... [-Wmisleading-indentation]
     if((ptr-message) % 4 > 0)
     ^~
crypto.c:886:49: note: ...this statement, but the latter is misleadingly indented as if it were guarded by the ‘if’
         memcpy(ptr, ZERO, 4-((ptr-message)%4)); ptr+=4-((ptr-message)%4);
                                                 ^~~
crypto.c:826:12: warning: variable ‘koffset’ set but not used [-Wunused-but-set-variable]
     int z, koffset=0, is_qos=0;
            ^~~~~~~
<builtin>: recipe for target 'crypto.o' failed
make[1]: *** [crypto.o] Error 1
make[1]: Leaving directory '/home/attacker/aircrack-ng-1.1/src'
Makefile:18: recipe for target 'all' failed
make: *** [all] Error 2

 15 
 on: October 12, 2018, 05:56:28 AM 
Started by george369 - Last post by George
Yes no problem at all.
Please let me know how to proceed.
Thanks you.

 16 
 on: October 11, 2018, 07:01:53 PM 
Started by george369 - Last post by misterx
Would it be possible to SSH on the Kali VM to test a few things (compilation and different parameters for configure)? No need for root, a regular user is just fine.

 17 
 on: October 11, 2018, 03:52:55 PM 
Started by george369 - Last post by misterx
Thank you

 18 
 on: October 11, 2018, 03:44:48 PM 
Started by george369 - Last post by George Siamas
Yes of course.
https://github.com/aircrack-ng/aircrack-ng/issues/1975
Thank you for your help.

 19 
 on: October 11, 2018, 02:47:17 PM 
Started by george369 - Last post by misterx
Looks like a bug, could you open one in GitHub ( https://github.com/aircrack-ng/aircrack-ng/issues ) with the details from the first post and this last one?

 20 
 on: October 11, 2018, 12:56:02 PM 
Started by george369 - Last post by George Siamas
Thank you very much for the response.

What version of aircrack-ng are you running?
Version 1.4

And what is the output of lscpu?
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              1
On-line CPU(s) list: 0
Thread(s) per core:  1
Core(s) per socket:  1
Socket(s):           1
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               85
Model name:          Intel(R) Core(TM) i9-7900X CPU @ 3.30GHz
Stepping:            4
CPU MHz:             3312.006
BogoMIPS:            6624.01
Hypervisor vendor:   VMware
Virtualization type: full
L1d cache:           32K
L1i cache:           32K
L2 cache:            1024K
L3 cache:            14080K
NUMA node0 CPU(s):   0
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon nopl xtopology tsc_reliable nonstop_tsc cpuid pni pclmulqdq ssse3 fma cx16 pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand hypervisor lahf_lm abm 3dnowprefetch cpuid_fault invpcid_single pti ibrs ibpb stibp fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 invpcid rtm mpx avx512f avx512dq rdseed adx smap clflushopt clwb avx512cd avx512bw avx512vl xsaveopt xsavec xsaves arat arch_capabilities


Is it coming from a package or compiled from source?
Same error occurs either or.

If package, what OS?
DISTRIB_ID=Kali
DISTRIB_RELEASE=kali-rolling
DISTRIB_CODENAME=kali-rolling
DISTRIB_DESCRIPTION="Kali GNU/Linux Rolling"
PRETTY_NAME="Kali GNU/Linux Rolling"
NAME="Kali GNU/Linux"
ID=kali
VERSION="2018.4"
VERSION_ID="2018.4"
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="https://www.kali.org/"
SUPPORT_URL="https://forums.kali.org/"
BUG_REPORT_URL="https://bugs.kali.org/"

Running with VMWare on a Win10 machine.


If from source, what was the ./configure command?
./configure

Tried a fresh install of Kali but no luck. Also tried fresh installs of aircrack with and without avx512 (specified in ./configure command).

Thank you!


Pages: 1 [2] 3 4 ... 10