Aircrack-ng forum

Please login or register.

Login with username, password and session length
Advanced search  


Aircrack-ng 1.7 release

Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Message icon:

(Clear Attachment)
(more attachments)
Restrictions: maximum individual size 10240KB
Note that any files attached will not be displayed until approved by a moderator.
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Which Aircrack-ng program captures traffic? Lowercase:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: nikuszop
« on: December 21, 2021, 11:53:23 am »

I am trying to create a fake AP using airbase-ng. After setting my card into monitor mode and running airodump on a different terminal, I run airbase. Airbase terminal does not output any errors but the AP disappears after a while. Checking airodump I can see that the number of beacons stops at 278 every time.
Posted by: Salim
« on: May 31, 2020, 05:36:37 am »

I am facing the same problem. I'm using airbase-ng on Ubuntu 18.04.
In my case I noticed that it stops broadcasting after exactly 278 Beacon frames. Increasing the interval between packets increases the broadcasting time.
I'm wondering if you found any workaround ??
I'd really appreciate any help in solving this problem.
Posted by: r_0_y
« on: March 10, 2016, 09:17:01 pm »

I just need to know the version of aircrack-ng. You were thorough in the details.

Sorry for the delay, was out of the office for a week so I wasn't thinking about it.
I was using Airbase-ng 1.2 rc4
Posted by: misterx
« on: February 29, 2016, 11:06:07 pm »

I just need to know the version of aircrack-ng. You were thorough in the details.
Posted by: r_0_y
« on: February 29, 2016, 05:56:19 pm »

Is there anything from my setup I should dump / send to you to make reproducing it easier?
Posted by: misterx
« on: February 29, 2016, 05:13:28 pm »

I will have to look at this and try to reproduce it. There is probably a bug somewhere in airbase-ng (most likely memory leak).
Posted by: r_0_y
« on: February 29, 2016, 03:07:35 pm »

So no, it's still dropping after about 2 minutes or so now.

airbase's output spams about 5 or 6 of
Code: [Select]
[hh:mm:ss] Got direct probe request from [my phone's MAC] - "TestWifiNetwork"
and then stops broadcasting.

I've had it last a little longer when I try adding '-y' to the launch args (used to get a flood of probes from the nearby networks in the office), but to be honest I'm not exactly sure if ignoring those with '-y' is a good thing or not.

I also managed to break my SSL certificate somehow? But I think that's from also trying to get my redirect working in between this troubleshooting.
Posted by: r_0_y
« on: February 29, 2016, 02:54:00 pm »

It's a desktop FYI, but alright I'll try skipping changing the mac.
Posted by: misterx
« on: February 29, 2016, 02:39:48 pm »

You're attaching it correctly.

2 things you can try:
- Remove the macchanger step, some drivers really don't like it.
- Use a powered USB hub, sometimes the laptop cannot give enough power to the card.
Posted by: r_0_y
« on: February 29, 2016, 02:18:44 pm »

Well, as far as I can tell from network manager, it doesn't look like my adapter is trying to auto-connect to anything (i've never connected it to any network in the first place, it's been used as my AP since i set it up). But even after adding in those steps, it drops (it even seems to drop quicker now, but I could be imagining that).

Could it be a weird conflict with windows since this is all being set up as a VM though virtual box?

I've got the  ALFA adapter set to connect through to the Kali VM as an attached USB device, rather than a network adapter since i can't set it as a wireless device that way. Might that be the issue?
Posted by: r_0_y
« on: February 29, 2016, 01:48:41 pm »

Thanks I'll try that ASAP.
Posted by: musket33
« on: February 27, 2016, 07:39:10 am »

To roy

   Give this a try an see if it helps?

Open your Network Manager and uncheck ALL autoconnect selections thru the Network Manager menu.

For the device running airbase-ng

Make a monitor thru airmon-ng

airmon-ng start wlan0

Now do this

ifconfig wlan0mon down
iwconfig wlan0mon mode monitor
ifconfig wlan0mon up

Now do your airbase-ng commands

You could leave the internet connected device ie I think your example is using eth0 have a connect auomatically to the internet setting.

You could use netmanmac1-3 to spoof you r mac thru Network Manager and also turn off the autoconnect settings.

See Kali linux forums.

We are running airbase-ng thru Pwnstar9.0 and not having any problems.
Posted by: r_0_y
« on: February 25, 2016, 07:30:50 pm »

So this time, using
Code: [Select]
airbase-ng --essid "FreeWifiThing" -c 2 -v wlan0mon

It lasted a whopping 19 minutes and 43 seconds.
The last output line was nothing special and a random broadcast probe from some nearby device.

I tried connecting my phone to the AP, and it worked surprisingly well with loading apps that use the interner (twitter, baconreader, flipboard), but struggled a ton to load full on webpages (wikipedia,,
Posted by: r_0_y
« on: February 25, 2016, 07:04:24 pm »

I've got a Kali2.0 VM set up with the newest (as of this post) update of aircrack-ng.
Using an ALFA AWUS063H with a ALFA APA-M04 7dBi pannel antenna (haven't tried using the default, but I really don't think that's my issue here).

I've got a script that sets up dhcpd and my iptables for default firewall stuff (typed out below), and even though the throughput is garbage, it at least works to the extent that it gives my attached device a valid ip and DNS server info and lets me connect (slowly) to the internet.

The trouble comes in every time after at least 7 minutes, where nothing changes in airbase-ng's output, but the SSID just stops broadcasting.

How I start airbase-ng:
Code: [Select]
ifconfig wlan0 down
maccahnger -r wlan0
ifconfig wlan0 up
airmon-ng check kill
airmon-ng start wlan0
airbase-ng -e FreeWifiOrWhatever -c 2 wlan0mon

Code: [Select]
#firewall config and forwarding all traffic from at0 to eth0
ifconfig at0 up
ifconfig at0 netmask
service isc-dhcp-server stop
dhcpd -cf /etc/dhcp/dhcpd.conf
service isc-dhcp-server start
iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
iptables --append FORWARD -j ACCEPT --in-interface at0
echo "1" > /proc/sys/net/ipv4/ip_forward

Gonna keep running airbase-ng in verbose to try and spot anything that might point to an issue, but I have no idea why this keeps happening.

I'd really appreciate some advice / clarification / help on this, thanks.