Aircrack-ng forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Aircrack-ng 1.6 release


Post reply

Name:
Email:
Subject:
Message icon:

Attach:
(Clear Attachment)
(more attachments)
Restrictions: maximum individual size 10240KB
Note that any files attached will not be displayed until approved by a moderator.
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Which Aircrack-ng program captures traffic? Lowercase:

shortcuts: hit alt+s to submit/post or alt+p to preview


Topic Summary

Posted by: misterx
« on: June 16, 2021, 12:29:53 am »

Likely a wireless card (hardware) limitation. FYI, you responded to a 3+ year old thread.
Posted by: MAXPG
« on: June 15, 2021, 08:39:54 pm »

I had the same issue, only capturing 2 of 4 out of the packets. I was able to capture all 4 when I used my kindle with the WiFi. My guess is that it has limitations based on what devices are connected.
Posted by: robertkjonesjr
« on: September 09, 2017, 08:00:26 pm »

There was a regression in the kernel with the RT driver, see

https://ask.wireshark.org/questions/53260/cannot-capture-frames-other-than-broadcast-or-multicast-over-wlan

for some discussion.  It looks like the 4.4 series kernel fixed it, at least on x86.  Cannot say what an ARM kernel might or might not have. 

I'd validate what you see with tcpdump or Wireshark and that could isolate whether it is a modulation issue (i.e. frames are sent at a modulation that this card cannot read) or if you have the issue where promiscuous mode does not work due to the kernel regression.  Post a packet capture file if you are not sure how to interpret what you see.
Posted by: branon
« on: September 09, 2017, 12:45:10 pm »

For Kali I'm using 4.4.50-v7

I also tried Ubuntu MATE with 4.4.31-v7+
But results are the same
Posted by: robertkjonesjr
« on: September 04, 2017, 07:27:00 pm »

What kernel are you using?
Posted by: branon
« on: September 03, 2017, 05:30:07 pm »

Hi, guys,

I have similar problem, therefore did not wanted to create separate thread for that.
I'm running Kali Linux on Raspberry pi 3.
Together with AWUS036NH (or at least I though this is the board).

Four way handshake does not seam to be recorded no matter what I do.
I tried to move all devices physically close (they are on the same table) - WiFi router I'm testing + raspberry with network card and My windows PC connected to WiFi network.
Even when I'm repeatedly restarting PC and connecting it back to WiFi network, handshake is not captured.
I also tried restarting android phone connected to the same WiFi but it had not provided any batter results.

I also thought it might be a problem with only 802.11n.
Therefore in router settings I marked that 802.11g would be used for network.
After repeating tests I still got the same results - no handshake.

So at the moment I'm thinking that it might be a hardware problem.
I checked label on the back of my network card.
Label says that it is AWUS036H (and not AWUS036NH as it was written on the box I received it in).
Also, MAC address written on it has prefix of 00:FF:00.
I tried to look it up, but it does not seam to be valid address: http://coffer.com/mac_find/?string=00%3AFF%3A00
So I took this device a part.
Board itself looks quite fake - it does not have any serial numbers or anything and look pretty simplistic.
Only number written on it is YHMB3070AT-L.
I tried googling it but it does not seam to be anything meaningful.

Also if overall board is supposed to look like this - https://duckduckgo.com/?q=awus036nh+board&iar=images&iax=1&ia=images&iai=https%3A%2F%2Fwikidevi.com%2Fw%2Fimages%2Fthumb%2Fc%2Fc6%2FALFA_Network_AWUS036H_1000_board_top_rfshieldremoved_noscan.jpg%2F300px-ALFA_Network_AWUS036H_1000_board_top_rfshieldremoved_noscan.jpg
It is definitely not that.

However board I have on its chip have engraved (Ralink 3070L)
So should theoretically it still could be used as it have supported chip? (Ofc assuming chip is not fake as well).
Or is it just batter to throw away this kind of board and get a new one?
If so, maybe somebody has some recommendations how to find board on internet which would not be fake? :D

Posted by: misterx
« on: August 27, 2017, 02:34:23 am »

There is no a/c. 802.11a cannot be monitored with a card that doesn't support 802.11a.
Posted by: Darkforce16
« on: August 27, 2017, 12:08:05 am »

Hi thanks. So as long as there's an "a" there shouldn't be a problem listening to traffic on 5 Ghz. I'm going to try a cheap b/g/n USB device in hopes I can see my AP with proper display of encryption in airodump-ng. If that doesn't work, then i need a device with a/b/g/n. If the encryption still doesn't work then I guess its a bug.

Btw a/c was introduced in Dec 2013 according to wiki. Its pure 5ghz spectrum though.
https://en.m.wikipedia.org/wiki/IEEE_802.11

Thanks for your notes.
Posted by: misterx
« on: August 25, 2017, 05:16:20 pm »

Let's break it down for you as you are minsunderstanding the different standards:

802.11b/g is 2.4GHz
80.211a is 5GHz
802.11n can either be on 2.4 or 5GHz (or both) depending on the card. If the card says 802.11b/g (or nothing), then it's 2.4GHz only. If it says 802.11a/b/g/n, then it's both. There are cases where it's 5GHz only but they're rare.
802.11ac is 5GHz only due to the amount of spectrum required.

So, your 802.11b/g/n is 2.4GHz only.

There is no such thing as a/c.
Posted by: Darkforce16
« on: August 25, 2017, 04:15:24 pm »

Hi Misterx doesn't the AWUS036NHA card with (n) support not good enough? 802.11n crosses over to the 5 ghz stream i would think and should listen on both 4 and 5 Ghz.

Does this mean in order for airodump-ng to capture a handshake on 5 Ghz that the attackers card must be an A/C compatible? It won't work with a N supported card?
Is this also why my airodump-ng shows my dual AP as WEP on the 5 Ghz AP MAC?  My listening device is B/G. TP-LINK TL-WN321G v2. My AP is a Cisco Linksys SmartWi-Fi EA6500.
Basically im searching on how to capture 5 ghz handshakes.
Posted by: misterx
« on: August 25, 2017, 02:43:28 am »

Well, look on the router itself.

None of the cards you mention support 5GHz.
Posted by: Darkforce16
« on: August 25, 2017, 02:31:34 am »

What doesn't makse sense is he said he had also 802.11n, which should capture in 5Ghz.

Is there a way to know what a remote client or AP is setup under?
Posted by: misterx
« on: August 24, 2017, 09:21:16 pm »

What probably happens is the handshake is done in 802.11n or ac and the card is not able to capture in that mode.
Posted by: weatherman
« on: August 24, 2017, 08:48:02 pm »

No matter what I do, aircrack never captures a WPA handshake. I've tried sending deauthentication packets, and even connecting to the targeted access point with my phone (I'm testing my own equipment, so I know the password). None of this works, and the handshake is never captured.

I am currently running Kali Linux as my primary OS, and I have tested aircrack with an Alfa AWUS036NHA (b/g/n) and an Alfa AWUS036H (b/g) to no avail. The drivers for these two wifi adapters were already pre-installed in Kali, so I'm fairly sure it's not a driver error.

If anyone knows anything about this issue, some insight would be greatly appreciated.