Aircrack-ng forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Aircrack-ng 1.7 release

Pages: [1] 2 3 ... 10
 1 
 on: September 25, 2022, 07:26:37 pm 
Started by umaric7 - Last post by Snafu
I know this is an old thread but in case anyone else is interested, I've had good luck with the AWUS036ACH card running Kali on a Raspberry Pi.
Just make sure you download the drivers via: apt install realtek-rtl88xxau-dkms


 2 
 on: September 13, 2022, 06:49:33 am 
Started by lushanclous - Last post by lushanclous
Please help, is it a problem with this chip, do I need to buy another network card

 3 
 on: September 13, 2022, 06:48:14 am 
Started by lushanclous - Last post by lushanclous
I use ASUS AX56 network card to turn on monitor mode, the attack makes the device offline, but can't get the handshake packet, the chip is rtl8852au, I have the driver ready --- from Google Translate

 4 
 on: September 02, 2022, 07:57:52 pm 
Started by programmer - Last post by misterx
1. 30MHz, not with airodump-ng, and very likely not this device/driver
2. My guess would be to set the regulatory domain to that: "iw reg set XX"

 5 
 on: September 01, 2022, 03:23:49 pm 
Started by programmer - Last post by programmer
Hi every one i have installed parrot os after that i pluged in my alfa usb AWUS036ACH adapter and installed rtl88xxau-mdk i start airmon-ng and also sudo airodump-ng —band a wlan0 its show 5ghz wifi wich have only 40Mhz channel width and its show me only US and Pak country region 5ghz devices like Power beem M5 my question is that :

    How can i see 20Mhz or 30Mhz channel channel frequencies
    How can i see Australia and any country region device

i will be very thankful if anyone solve my issue

 6 
 on: August 22, 2022, 03:15:18 pm 
Started by eulalawrence - Last post by theflyingdutchman
I have the same problem with my two Alfa AWUS036ACHM cards. I've updated aircrack to 1.7 but it seems that aireplay can't deauth 5ghz band

 7 
 on: August 22, 2022, 02:43:03 am 
Started by eulalawrence - Last post by eulalawrence
Updated to aircrack 1.7 and followed all the steps above in running the deauth again. I also set my router to 802.11ac and now im about 10 feet away from my router. Despite this Im still getting the exact same results. Im getting barely any ACKS on my 5ghz AP.

┌──(kali㉿kali)-[~]
└─$ sudo aireplay-ng --deauth 0 -a 24:F5:A2:04:9B:34 -c B0:73:5D:D2:D9:5D wlan0mon
22:36:24  Waiting for beacon frame (BSSID: 24:F5:A2:04:9B:34) on channel 157
22:36:25  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 0 ACKs]
22:36:25  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 0 ACKs]
22:36:26  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 1 ACKs]
22:36:27  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 1 ACKs]
22:36:27  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 2 ACKs]
22:36:27  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 0 ACKs]
22:36:28  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 0 ACKs]
22:36:29  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 2 ACKs]
22:36:30  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 1 ACKs]
22:36:31  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 5 ACKs]
22:36:31  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 3 ACKs]
22:36:32  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 1| 3 ACKs]
22:36:33  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 6 ACKs]
22:36:33  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0| 3 ACKs]

But significantly more ACKs on my 2.4ghz AP,

┌──(kali㉿kali)-[~]
└─$ sudo aireplay-ng --deauth 0 -a 24:F5:A2:04:9B:33 -c B0:73:5D:D2:D9:5D wlan0mon
22:40:47  Waiting for beacon frame (BSSID: 24:F5:A2:04:9B:33) on channel 7
22:40:47  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [62|65 ACKs]
22:40:48  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [19|62 ACKs]
22:40:48  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [32|67 ACKs]
22:40:49  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [66|69 ACKs]
22:40:50  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [63|66 ACKs]
22:40:51  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 4|64 ACKs]
22:40:51  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0|64 ACKs]
22:40:52  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0|62 ACKs]
22:40:52  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 3|66 ACKs]
22:40:53  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0|64 ACKs]
22:40:54  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0|65 ACKs]
22:40:54  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [46|63 ACKs]
22:40:55  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [66|69 ACKs]
22:40:56  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [66|68 ACKs]
22:40:56  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 4|63 ACKs]
22:40:57  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 0|64 ACKs]
22:40:58  Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 1|62 ACKs]
22:40:5^C Sending 64 directed DeAuth (code 7). STMAC: [B0:73:5D:D2:D9:5D] [ 4|27 ACKs]

I then decided to just test if packet injection in general is working. For my 5ghz AP packet injection for some reason is not working at all

┌──(kali㉿kali)-[~]
└─$ sudo iwconfig wlan0mon channel 157
                                                                                                                   
┌──(kali㉿kali)-[~]
└─$ sudo aireplay-ng --test wlan0mon 
22:50:50  Trying broadcast probe requests...
22:50:52  No Answer...
22:50:52  Found 1 AP

22:50:52  Trying directed probe requests...
22:50:52  24:F5:A2:04:9B:34 - channel: 157 - '5GHz'
22:50:58   0/30:   0%

But on the other hand when running the test on my 2.4ghz AP it works fine

┌──(kali㉿kali)-[~]
└─$ sudo aireplay-ng --test wlan0mon
22:52:37  Trying broadcast probe requests...
22:52:37  Injection is working!
22:52:39  Found 3 APs

22:52:39  Trying directed probe requests...
22:52:39  24:F5:A2:04:9B:33 - channel: 7 - '2.4GHz'
22:52:42  Ping (min/avg/max): 21.575ms/51.449ms/158.056ms Power: -20.60
22:52:42  20/30:  66%

22:52:42  14:EB:B6:05:F2:AB - channel: 7 - 'Redacted'
22:52:47  Ping (min/avg/max): 8.803ms/35.619ms/77.291ms Power: -69.67
22:52:47   6/30:  20%

22:52:47  CC:D4:2E:67:E5:B8 - channel: 7 - 'Redacted'
22:52:53   0/30:   0%

Why isnt packet injection working on 5ghz band?

 8 
 on: August 21, 2022, 08:15:09 pm 
Started by eulalawrence - Last post by misterx
It should be 'os=any dist=any'.

It works fine on Ubuntu, but on Kali, for some reason it doesn't see 1.7 as higher than 1.6.
For the time being, download the deb, and install with dpkg: dpkg -i aircrack-ng_1.7-1_amd64.deb)

 9 
 on: August 21, 2022, 05:24:22 am 
Started by eulalawrence - Last post by eulalawrence
Hi yes you are correct I am still on aircrack 1.6. I tried installing the latest version from packagecloud but am having difficulty getting it to work. From the aircrack installation instructions I went to the packagecloud site (https://packagecloud.io/aircrack-ng/release/packages/any/any/aircrack-ng_1.7-1_amd64.deb) and ran the first command. Apparently kali is not supported so I cant get the package installation to work.

┌──(kali㉿kali)-[~/Downloads]
└─$ curl -s https://packagecloud.io/install/repositories/aircrack-ng/release/script.deb.sh | sudo bash
Detected operating system as kali/kali-rolling.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/aircrack-ng_release.list...curl: (22) The requested URL returned error: 404


Unable to download repo config from: https://packagecloud.io/install/repositories/aircrack-ng/release/config_file.list?os=kali&dist=kali-rolling&source=script

This usually happens if your operating system is not supported by
packagecloud.io, or this script's OS detection failed.

You can override the OS detection by setting os= and dist= prior to running this script.
You can find a list of supported OSes and distributions on our website: https://packagecloud.io/docs#os_distro_version

For example, to force Ubuntu Trusty: os=ubuntu dist=trusty ./script.sh

If you are running a supported OS, please email support@packagecloud.io and report this.

I decided then to attempt to overwrite the os and dist settings. I loosely remember kali being based off debian 8 or 7? The repo set up seems to work but kali cant seem to find aircrack 1.7

┌──(kali㉿kali)-[~/Downloads]
└─$ curl -s https://packagecloud.io/install/repositories/aircrack-ng/release/script.deb.sh >> install.sh
                                                                                                                                                                                                                                           
┌──(kali㉿kali)-[~/Downloads]
└─$ chmod +x install.sh                                                                                 

┌──(kali㉿kali)-[~/Downloads]
└─$ sudo os=debian dist=jessie ./install.sh
Detected operating system as debian/jessie.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing debian-archive-keyring which is needed for installing
apt-transport-https on many Debian systems.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/aircrack-ng_release.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

The repository is setup! You can now install packages.
Detected operating system as debian/jessie.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing debian-archive-keyring which is needed for installing
apt-transport-https on many Debian systems.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/aircrack-ng_release.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

The repository is setup! You can now install packages.

┌──(kali㉿kali)-[~/Downloads]
└─$ sudo apt-get install aircrack-ng=1:1.7-1
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package aircrack-ng is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Version '1:1.7-1' for 'aircrack-ng' was not found

What am I doing wrong here?



 10 
 on: August 20, 2022, 07:16:13 pm 
Started by eulalawrence - Last post by misterx
Kali still has aircrack-ng 1.6 despite 1.7 being released for a few months. I know there was some bug about 5GHz in 1.6, but I don't recall when it was exactly fixed.

So, you can compile and install from sources (or use our packages), then try again, and report back.

Installation is explained in the wiki (from sources) and the README.md file, and also in the blog (for the packages).

Three suggestions:
- Run airmon-ng check kill prior to putting the card in monitor mode, as it can interfere with airodump-ng as well.
- Don't be too close, as it's as bad as being too far, and leads to packet loss. Try something like 10 feet.
- Make sure your AP is set to 802.11ac (and not 11ax).

Pages: [1] 2 3 ... 10