Aircrack-ng forum

Please login or register.

Login with username, password and session length
Advanced search  


Aircrack-ng 1.6 release

Post reply

Message icon:

(Clear Attachment)
(more attachments)
Restrictions: maximum individual size 10240KB
Note that any files attached will not be displayed until approved by a moderator.
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Which Aircrack-ng program replays traffic? Lowercase:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: misterx
« on: October 30, 2021, 08:25:03 pm »

Thanks for the update :)
Posted by: jesperst
« on: October 28, 2021, 11:31:35 pm »

Sorry I didn't change the relatek, obviously update the driver/firmware that you have
Posted by: jesperst
« on: October 28, 2021, 11:29:27 pm »

Updating firmware/driver helped me.

>sudo apt update

>sudo apt install firmware-realtek

then reboot

It didn't capture anything before the update and works like a charm since then. Hope it helps 8)
Posted by: Ujjwal
« on: August 23, 2021, 07:19:06 am »

I have the same issue it worked when i tried it for the first time but when i tried it for the second time airodump-ng is not showing any APs.
Posted by: Unai
« on: February 12, 2021, 05:12:22 am »

Same laptop, same issue. Is there any solution?
Posted by: 刘一阳
« on: June 02, 2020, 05:24:35 am »

Yes it's the matter of "Qualcomm Atheros QCA9377", I have this in my laptop(Lenovo 330s) too. And I got exactly the same error as reply #3.
Once I use an external "realtek RTL8192EU",airodump shows all the APs correctly
Posted by: Javiervs
« on: June 08, 2019, 09:39:41 am »

Thanks misterx and dmkgrim80 for your replies. After a Lenovo update left my Kali partition inaccessible, I've decided to buy an Alfa Network AWUS036NHA and use VirtualBox from now on. For that reason I can't test anything else, but maybe a possible solution may be to kill the Bluetooth service, since it also depends on the wireless device. That's all speculation from my part.

If you want, close this topic or keep it open so more people can look for answers regarding the device, and eventually find a solution.

Thank you very much!
Posted by: dmkgrim80
« on: June 08, 2019, 04:33:34 am »

Qualcomm Atheros QCA9377 is troublesome. Dont know if the firmware is crashing or not. I have Qualcomm Atheros QCA9377 in a Acer Aspire E15.

my Qualcomm Atheros QCA9377 just isnt wireless network adapter its also a bluetooth chip 2 in 1 functions.

Posted by: misterx
« on: June 06, 2019, 06:14:16 pm »

There seems to be something wrong with the hardware as shown in the logs  you attached:

[   33.604258] pcieport 0000:00:1c.0: AER: Corrected error received: 0000:00:1c.0
[   33.604274] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
[   33.604283] pcieport 0000:00:1c.0:   device [8086:9d12] error status/mask=00001000/00002000
[   33.604289] pcieport 0000:00:1c.0:    [12] Timeout       

I was referring to which points to the mailing lists. Mention the error above that keeps repeating (as well as an output of lspci).
Posted by: Javiervs
« on: June 06, 2019, 11:41:09 am »

I have done the dist-upgrade you suggested, but it's still not showing APs. I've also checked rfkill and it says there's nothing blocked. What I found in google about the errors from dmesg is that there might be some incompatibility with the hardware and Linux, or some kernel bug, I'm not sure. But the people posting those errors are having serious problems with their wifi connection and their logs are flooded with that error to the point they weigh many GB after a single week, while my wifi works perfectly fine, so I have no idea what it is about.

I have attached the dmesg log so you can take a look. If something else comes to your mind, let me know and I'll try it, or if you need any other info or logs, just ask me and I'll provide them.

Thank you.

Links about the AER corrected error:

Edit: I forgot about the Linux-wireless mailing list you suggested. I have googled it but I'm not sure what it is. Am I supposed to send an email to that address about the issue?
Posted by: misterx
« on: June 06, 2019, 02:12:15 am »

airmon-ng kills/stops network managers. In Kali, it's just service network-manager start to restart it. By the way, killing network manager then putting in monitor mode is the correct way to do it.

Two things you can try:
- Do a dist-upgrade, it will upgrade the kernel, then reboot and try again.
- Check that rfkill doesn't report the device as blocked.

Have you googled that error message from dmesg?

Other than that, I'm pretty much out of ideas of what is wrong, I would have done the exact same steps as you did. Maybe something's wrong with the firmware or the hardware itself. You could bring it up to Linux-wireless mailing list.
Posted by: Javiervs
« on: June 05, 2019, 01:45:56 pm »

I'm a newbie at using Aircrack, Linux, and hacking in general and I'm having trouble capturing traffic with airodump-ng.

I'm using kali, installed on a partition on the main drive in dual boot with Windows 10. My laptop is a Lenovo Yoga 720 with an integrated wireless device Qualcomm Atheros QCA9377, which, to my knowledge, should theoretically support mointor mode.

I have followed these steps:

- Searched on google for similar problems.
- Used apt-get update and apt-get upgrade.
- Used airmon-ng check kill and then airmon-ng start wlan0, then airodump-ng wlan0mon
- No AP appear, despite being many WiFi in range.
- No error messages appear up until this point and every step seems to work fine except for not showing any APs.
- Executing dmesg shows up many "AER: Corrected error received". Apart from that, I can only see a message saying "device wlan0mon entered promiscuous mode" when entering airodump-ng wlan0mon, but I'm not sure what I'm looking for.
- Using airmon-ng check kill permanently disables my WiFi connection until restart, while entering airmon-ng start wlan0 without entering before airmon-ng check kill disables my connection only until I enter airmon-ng stop wlan0mon. I'm not sure if this is normal behavior, but at this point both actions result in no APs showing up.

I'd appreciate any help regarding how to solve the issue or how to proceed in order to troubleshoot it.

Thanks in advance.