Please login or register.

Login with username, password and session length
Advanced search  


Aircrack-ng 1.6 release

Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Message icon:

(Clear Attachment)
(more attachments)
Restrictions: maximum individual size 10240KB
Note that any files attached will not be displayed until approved by a moderator.
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Which Aircrack-ng program replays traffic? Lowercase:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: kcdtv
« on: December 02, 2016, 12:21:57 pm »

The -c 2 in your command line is the issue.
Code: [Select]
-c dmac   : set Destination  MAC address i guess you want to use channel 2, aireplay-ng will be set in the channel you are sniffing with airodump-ng, you don't have to use anything for that. 
Posted by: eapolsniper
« on: November 29, 2016, 05:16:48 pm »


I'm trying to de-authenticate a wireless client but I'm running into an issue. Every time I try, I receive the message "Invalid destination MAC address". I've verified that the MAC is correct from inside the Access Point and through beacon requests from the device itself.

Syntax used:

aireplay-ng --deauth 10 -c 2 -a 34:97:F6:07:35:28 -c 18:B4:30:5A:DB:21 wlan0mon
Invalid destination MAC address.
"aireplay-ng --help" for help.

I've verified:

* Card is supported (Alfa AWUS051NH2) Also tried 2 other Alfa cards of varying models and received the same error
* -9 test works as expected
* I'm at the latest version of Aircrack (and Kali)
* I've tried both -c and -h, though I believe -c is the syntax I should be using.
* I've tried turning it off and back on again
* I ran airmon-ng check kill before setting the device into monitor mode.
* I tried -0 and --deauth
* I tried setting deauth attempts to 0, 10, 100, 1000, etc

I'm using the following syntax, anyone see my mistake or have ideas on how I can run the deauth?