Please login or register.

Login with username, password and session length
Advanced search  


Aircrack-ng 1.6 release

Post reply

Message icon:

(Clear Attachment)
(more attachments)
Restrictions: maximum individual size 10240KB
Note that any files attached will not be displayed until approved by a moderator.
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Which Aircrack-ng program captures traffic? Lowercase:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Tesla Tech
« on: July 21, 2020, 11:49:56 pm »

Thanks Bro! I was able to get 4 Way Handshake Using Kali 2018.1 on live persistence USB.... Can u plss provide the link of Kali 2019.1 since the experience on kali 2018.1 was very laggy and not that comfortable... :) :) :D   
Posted by: madder
« on: July 18, 2020, 05:37:29 pm »

packet sniffing worked for me on 2018.2 live
not sure of injection works
Posted by: Tesla Tech
« on: July 18, 2020, 08:28:02 am »

Hi geeks... If I used  kali linux 2018.1 xfce , on live usb persistence mode, will it work.. Whether I could be able to see Air packets using Qualcomm Atheros QCA9377 on my terminal.. PLSSSS reply!!!!! I am waiting for your answers    :) :) :)
Posted by: madder
« on: July 11, 2020, 12:15:18 pm »

unfortunately i'm now facing a new issue with packet injection with aireplay-ng  (mdk3 doesn't seem to work either ) 
output of aireplay-ng -9 [interface] in monitor mode
Code: [Select]
17:04:45  Trying broadcast probe requests...
17:04:46  No Answer...
17:04:46  Found 2 APs

17:04:46  Trying directed probe requests...
17:04:46  F8:ZZ:85:ZZ:8E:57 - channel: 11 - 'Art Image'
17:04:52   0/30:   0%

17:04:52  E4: ZZ5D:ZZ:19:70 - channel: 10 - 'TOPNET8sdssd'
17:04:58   0/30:   0%
output of iwconfig
Code: [Select]
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0mon  IEEE 802.11  Mode:Monitor  Frequency:2.457 GHz  Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
MACs don't look correct cuz I changed them  :P
deauthenticate output with aireplay or mdk3 doesn't show any errors (looks clean and functional ) while it's not doing anything basically (tested  on my own network) and worked like charm with an other interface.
Posted by: madder
« on: July 10, 2020, 06:05:52 pm »

From  /lib/firmware/ath10k/QCA9377  on kali 2018.2
and cloned it
Posted by: misterx
« on: July 09, 2020, 06:13:58 pm »

Where did you find this firmware?
Posted by: madder
« on: July 09, 2020, 10:58:27 am »

I Fixed it

airodump works like charm on kali 2018 build because  Atheros QCA9377 uses firmware-5.

the problem occurs when using firmware-6 on kali 2020 and 2019 builds
so what I did is use the firmware-5 from 2018 and done

here is a link for the firmware-5 you need along with board.bin and borard-2.bin.
make a backup for the firmware-6 in-case:

cp -R /lib/firmware/ath10k QCA9377 /Desktop

download my firmware and extract if needed:
cp -R /Downloads QCA9377  /lib/firmware/ath10k
sudo reboot

airodump should work now  8)
Posted by: mrbernabeu
« on: March 23, 2020, 08:49:47 am »

i use same wirless card. its work with kali 2018 but not work with 2019 or 2020.
Posted by: madafakaz
« on: October 20, 2019, 03:06:23 pm »

here's how it works and why:

when you start mon interface with airmon-ng and have sta interface disconnected airodump will not find any AP
if you have sta interface connected to an AP and run airodump on mon interface it will find AP
or if you put sta interface down e.g. ifconfig wlanX down and leave only mon interface active airodump will find AP

this is at least how it works with qca9880 and it's probably the same with qca6174

i just check this with qca9377, it works only if connected to an AP at the same time, and that is on clean 16.04.6 ubuntu system while my qca9880 runs on patched 10.04 ubuntu. if patched all drivers settings on 16.04.6 behaviour would most likely be identical
Posted by: dimitrispr
« on: March 04, 2019, 06:40:49 am »

No, the same. Its probably the network card. No other possible explanation. Gonna buy an alfa. Thank you for your help
Posted by: misterx
« on: March 03, 2019, 03:44:28 pm »

I'm aware it supports monitor mode, with the exception of QCA6xxx series (whose firmware is constantly crashing).

I have no idea why it's not reporting anything (it should). Does the injection test (-9) shows anything useful?
Posted by: dimitrispr
« on: March 03, 2019, 06:40:32 am »

What I also noticed is that airbase-ng AP doesn't appear on wireless networks when I run the command: airbase-ng -e test -c 11 -v wlp3s0mon
Posted by: dimitrispr
« on: March 03, 2019, 06:20:18 am »

Hi, thanks for your answer.

I killed all the processes prior posting this. What I didn't do is check dmesg. So, after clearing it, I killed the processes again and put my card in monitor mode.
The following error appears:

ath10k_pci 0000:03:00.0: failed to install key for vdev 0 peer ff:ff:ff:ff:ff:ff: -110
[ 2841.179182] wlp3s0: failed to remove key (0, ff:ff:ff:ff:ff:ff:) from hardware (-110)

Tried to google it but can't figure out what this means.

I even installed kali linux on my pc but still the same results.

AS far as my network card is concerned

Supported interface modes:
       * IBSS
       * managed
       * AP
       * AP/VLAN
       * monitor
       * mesh point
       * P2P-client
       * P2P-GO
       * P2P-device

Posted by: misterx
« on: March 01, 2019, 02:08:44 pm »

You must kill the network managers prior to putting in monitor mode.

There might be messages in dmesg indicating what's wrong, so, it might be better to clear it before running airmon-ng.

Try that and report back.
Posted by: dimitrispr
« on: March 01, 2019, 06:28:45 am »

Issue: when i run airodump-ng wlp3s0mon, no results appear.

I recently installed all kali linux tools on Ubuntu 18.04 LTS from this git repo

My chipset is the following and it supports monitor mode

root@Dimitris:~# airmon-ng
PHY    Interface    Driver          Chipset
phy0   wlp3s0      ath10k_pci   Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

  • I tried killing all the conflicting processes and daemons
  • I use my interface in monitor mode
  • I've updated my system
  • I've updated my wireless drivers

I literally tried everything I could think of.
What am I missing?