Aircrack-ng

Please login or register.

Login with username, password and session length
Advanced search  

News:

Aircrack-ng 1.6 release

Pages: [1]   Go Down

Author Topic: aireplay-ng in 5Ghz  (Read 11225 times)

bugged

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
aireplay-ng in 5Ghz
« on: May 23, 2016, 08:15:31 am »

hello everyone!

  I am studying 5Ghz injection but get stucked for some days. Here is what i did:
    adapter: RaLink chipset rt3572 rt2800usb;
    airmon-ng check kill; airmon-ng start wlan5 36;
    it turns to monitor mode, then wlan5mon is created;
    airodump-ng --channel 36 wlan5mon, after that it can capture packets from a 5Ghz ap;
 
  but when using aireplay-ng -0 to deauth, it always reports that:
        []waiting for beacons from mac:xxxxx...
        []no such bssid available. please specify a .....
  when aireplay-ng -9 wlan5mon, it finds no APs.

  What can i do? :'( Any suggestion will be appreciated!
Logged

bugged

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: aireplay-ng in 5Ghz
« Reply #1 on: May 23, 2016, 11:37:45 am »

    And now, I use aireplay-ng -D when starting deauth, then the DeAuth frames are sending...

    but nothing happens within the connection between clients and the AP,
 
    so, what's the problem? I need help...
Logged

misterx

  • Aircrack-ng Author
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1769
  • Aircrack-ng Author
    • Aircrack-ng
Re: aireplay-ng in 5Ghz
« Reply #2 on: May 23, 2016, 08:42:27 pm »

Try current svn and report back. A potential fix was pushed a day or 2 ago.
Logged

wafflewarrior

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Re: aireplay-ng in 5Ghz
« Reply #3 on: May 31, 2016, 12:26:00 pm »

Try current svn and report back. A potential fix was pushed a day or 2 ago.

I have the same problem, tried installing the current SVN as you suggested, after doing so, I found that aireplay-ng reports successful injection, however it finds no APs to test with. 

Despite that, I have one 5ghz router sitting right next to me, and I'm on the exact same channel as it.  Directed attacks only result in aireplay-ng reporting that it is looking for a beacon frame, which it never finds...

Here's some text

When looking for APs with injection test
Code: [Select]
sudo aireplay-ng -9 wlan1mon
12:04:05  Trying broadcast probe requests...
12:04:05  Injection is working!
12:04:07  Found 0 APs

Directed injection test:
Code: [Select]
sudo aireplay-ng -9 -a C0:C1:C0:D0:4B:6A wlan1mon
12:13:29  Waiting for beacon frame (BSSID: C0:C1:C0:D0:4B:6A) on channel 157

However I can clearly see this station in airodump-ng

Code: [Select]
CH 157 ][ Elapsed: 10 mins ][ 2016-05-31 12:22                                         
                                                                                                       
 BSSID              PWR RXQ  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID
                                                                                                       
 C0:C1:C0:D0:4B:6A  -16 100     5900      810    0 157  54e  OPN              5 GHZ BABY                     
                                                                                                       
 BSSID              STATION            PWR   Rate    Lost    Frames  Probe                             
                                                                                                       
 C0:C1:C0:D0:4B:6A  (my MAC address)  -38    6e-24      0      979  5 GHZ BABY                         
     

Any suggestion would be greatly appreciated.
Logged

misterx

  • Aircrack-ng Author
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1769
  • Aircrack-ng Author
    • Aircrack-ng
Re: aireplay-ng in 5Ghz
« Reply #4 on: May 31, 2016, 08:35:20 pm »

OK, I was able to reproduce and I confirm it's a bug.
Logged

yudidi

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Re: aireplay-ng in 5Ghz
« Reply #5 on: June 10, 2016, 06:52:13 am »

OK, I was able to reproduce and I confirm it's a bug.

this bug fixed?
Logged

misterx

  • Aircrack-ng Author
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1769
  • Aircrack-ng Author
    • Aircrack-ng
Re: aireplay-ng in 5Ghz
« Reply #6 on: June 10, 2016, 02:42:41 pm »

Not yet. I'm busy with a bunch of other things along with my full time job (which isn't Aircrack-ng yet).
Logged

yudidage

  • Guest
Re: aireplay-ng in 5Ghz
« Reply #7 on: June 18, 2016, 02:49:01 am »

kali1.1.0 kernel 3.18.0   aireplay-ng on 5G works.....
but I don‘t konw why.....
Logged

kcdtv

  • Experienced
  • Full Member
  • ********
  • Offline Offline
  • Posts: 210
Re: aireplay-ng in 5Ghz
« Reply #8 on: June 18, 2016, 12:55:31 pm »

Not yet. I'm busy with a bunch of other things along with my full time job (which isn't Aircrack-ng yet).
You should consider it : wage is high and the health insurance is one of the best in the market.
Quote from: yudiage
kali1.1.0 kernel 3.18.0
Thank you very much for the information: At least we can have a USB live with kali 1.0 and are able to inject in 5Ghz with this "walk around"
Good to know.
The reason? Blame system.d ! (I don't know at all; but i decided that i will always blame system.d when something goes wrong with latest kernel  :D )
Logged

yudidi

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Re: aireplay-ng in 5Ghz
« Reply #9 on: June 22, 2016, 04:44:49 am »

hello everyone!

  I am studying 5Ghz injection but get stucked for some days. Here is what i did:
    adapter: RaLink chipset rt3572 rt2800usb;
    airmon-ng check kill; airmon-ng start wlan5 36;
    it turns to monitor mode, then wlan5mon is created;
    airodump-ng --channel 36 wlan5mon, after that it can capture packets from a 5Ghz ap;
 
  but when using aireplay-ng -0 to deauth, it always reports that:
        []waiting for beacons from mac:xxxxx...
        []no such bssid available. please specify a .....
  when aireplay-ng -9 wlan5mon, it finds no APs.

  What can i do? :'( Any suggestion will be appreciated!


Is this bug salved?
Logged

kcdtv

  • Experienced
  • Full Member
  • ********
  • Offline Offline
  • Posts: 210
Re: aireplay-ng in 5Ghz
« Reply #10 on: June 22, 2016, 09:18:02 am »

What is the point to ask it repetitively?  ???
It won't make things happen faster...
Check the changelog of the new versions, if the bug is fixed it will appear here.
By the way; you an also try and install the last svn version and see it for yourself...   ;)
Logged

misterx

  • Aircrack-ng Author
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1769
  • Aircrack-ng Author
    • Aircrack-ng
Re: aireplay-ng in 5Ghz
« Reply #11 on: June 22, 2016, 08:18:03 pm »

We'll let you know when it is fixed.
Logged

wafflewarrior

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Re: aireplay-ng in 5Ghz
« Reply #12 on: June 28, 2016, 11:58:00 am »

Not sure if you did anything, but this works for me now  :).

I think I was trying in inject on a channel the card did not support, so it would just hang.  I'll take a look further to see if that was the case.
Logged
Pages: [1]   Go Up