Aircrack-ng forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Aircrack-ng 1.6 release

Pages: [1] 2 3   Go Down

Author Topic: Installing Backports Wireless Drivers - DON'T USE BACKPORTS ANYMORE!  (Read 74208 times)

pedropt

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 73

Some people have some difficulties to understand if they need to install backports drivers to use injection in aircrack package , i will explain everything i got knowledge until now and i will explain it to you .

1st of all , if you use a pentest distribution like Kali Linux , you will not need backports installed on your system except if you want to upgrade your drivers .
Kali Linux drivers are already prepared for injection when you install the OS for the first time .
this next image shows a test injection with kali linux original drivers :


this next image shows airodump scanning the networks around :


If you have a message when using airodump that says you to use the switch "--ignore-negative-one " after your commands , then you probably still have network-manager running .
To eliminate that message you only need to do this on terminal  :
Quote
airmon-ng check
and this will happen :


on this image airmon-ng says that processes : 18872 , 18893 , 18894 may give issues  in monitor mode .
all you have to do is use this command :
kill "process number"
Example :
Quote
kill 18872
and do this for all other processes .

If you want to kill all processes in a row , you just need to write in terminal :
Quote
airmon-ng check kill

New Adition

Network manager itself also may give some issues , because you are killing the opened processes that uses network but not killing network-manager  , so , if problem stays then open your terminal and write :
Quote
service network-manager stop

If you don't know how to restart your network manager again and network protocols , then write this when you finish your playing with aircrack and stop monitor mode :
Quote
service networking restart
service network-manager start
open nm-applet

If even after this explanation you still want to install backports drivers then here it is the normal installation of backports version : 3.16.2-1 without any patch to upgrade all wireless drivers from backports package .

Quote
sudo apt-get update && apt-get upgrade -y
sudo apt-get install linux-headers-$(uname -r)
cd /usr/src/
sudo wget http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.16.2/backports-3.16.2-1.tar.xz
sudo tar xvfJ backports-3.16.2-1.tar.xz
cd backports-3.16.2-1
sudo make defconfig-wifi
sudo make
sudo make install
sudo update-initramfs -u
reboot

To uninstall backports drivers from this current setting you just need to do this from terminal :

Quote
cd /usr/src/
cd backports-3.16.2-1
sudo make uninstall
sudo update-initramfs -u
reboot

Backports website : http://drvbp1.linux-foundation.org/~mcgrof/rel-html/backports/

Note : The same procedure of installation can be made also for new versions of backports .
If you are upgrading your current backports drivers then you must first uninstall the current ones , and then install the new version .


« Last Edit: April 17, 2018, 05:20:07 pm by misterx »
Logged

jWalker

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
Re: Installing Backports Wireless Drivers
« Reply #1 on: July 03, 2015, 01:36:50 pm »

Oh dear god thank you thank you!  Finally it all seems to be working as it should.  :)

I've got Kali installed on a a Mac in VirtualBox and VMware.  Then I ended up installing it as a dual boot - just so I could figure out if aireplay-ng didn't like something within a virtual environment or if it was something else entirely.

It was only after I did upgrades/updates on Kali (from a 1.1.0a-amd64.iso install - aircrack-ng 1.2 beta3) that aireplay-ng (1.2rc2) stopped working properly.  I had poor collection of AP's and usually nothing for clients until I did a deauth but still had no ACKS and no handshakes.

I also set up a HP box dual booting Ubuntu and Windows and aircrack-ng 1.2 rc2 was working fine in Ubuntu.  Both the Mac and HP box were the same distance from the AP (mine) and using the same USB wifi stick.

After installing backports, it solved all problems I'd been having on the Mac.

Cheers. :)
« Last Edit: July 04, 2015, 03:44:57 am by jWalker »
Logged

0xb105f00d

  • Guest
Re: Installing Backports Wireless Drivers
« Reply #2 on: July 26, 2015, 09:06:24 am »

Interesting, I've followed these instructions (minus the version - I used the latest version available) for installing backports and everything. Plus I've followed countless other instruction sets online to get this TP-Link adapter to work with Kali 1.10c running on my VMware Workstation 11.x distro.

Windows detects the device. I connect it to the VM and disconnect from the host. I run lsusb and the device is connected and recognized as the Atheros chipset. But the device REFUSES to become an active wireless adapter on my linux machine. It will work in windows. With or without manufacturer specific drivers so the adapter is fine.

Please help, I have spent hours upon hours of debugging this problem with no solution as of yet. Maybe there is something simple that I am missing or a simple conflict of version or hardware combinations. Currently the only device I can get to function as a wlan device is a nano USB adapter from monoprice running on a Realtek chipset. It does not support injection however.

LSUSB
Quote
root@kali:~# lsusb
Bus 002 Device 008: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 002 Device 006: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 001 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

There should be a wlan0 and a wlan1 device listed here...
Quote
root@kali:~# iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on
         
lo        no wireless extensions.

I did however find an error when trying to load the driver requested using dmesg command in terminal:
Quote
[41726.802845] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[41726.803474] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[41728.438853] usb 2-2: new high-speed USB device number 7 using ehci-pci
[41728.746803] usb 2-2: config 1 interface 0 altsetting 0 bulk endpoint 0x83 has invalid maxpacket 64
[41728.746805] usb 2-2: config 1 interface 0 altsetting 0 bulk endpoint 0x4 has invalid maxpacket 64
[41728.753823] usb 2-2: New USB device found, idVendor=0cf3, idProduct=9271
[41728.753826] usb 2-2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[41728.753827] usb 2-2: Product: USB2.0 WLAN
[41728.753828] usb 2-2: Manufacturer: ATHEROS
[41728.753829] usb 2-2: SerialNumber: 12345
[41728.757279] usb 2-2: ath9k_htc: Firmware htc_9271.fw requested
[41728.757416] usb 2-2: firmware: direct-loading firmware htc_9271.fw
[41731.112528] usb 2-2: ath9k_htc: Firmware - htc_9271.fw download failed
[41731.112598] usb 2-2: ath9k_htc: USB layer deinitialized
[41736.178985] usb 2-2: USB disconnect, device number 7
[41811.341316] usb 2-2: new high-speed USB device number 8 using ehci-pci
[41811.649681] usb 2-2: config 1 interface 0 altsetting 0 bulk endpoint 0x83 has invalid maxpacket 64
[41811.649684] usb 2-2: config 1 interface 0 altsetting 0 bulk endpoint 0x4 has invalid maxpacket 64
[41811.654742] usb 2-2: New USB device found, idVendor=0cf3, idProduct=9271
[41811.654743] usb 2-2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[41811.654744] usb 2-2: Product: USB2.0 WLAN
[41811.654745] usb 2-2: Manufacturer: ATHEROS
[41811.654746] usb 2-2: SerialNumber: 12345
[41811.658251] usb 2-2: ath9k_htc: Firmware htc_9271.fw requested
[41811.658374] usb 2-2: firmware: direct-loading firmware htc_9271.fw
[41811.910005] usb 2-2: ath9k_htc: Firmware - htc_9271.fw download failed
[41811.910095] usb 2-2: ath9k_htc: USB layer deinitialized

However I am not sure how to continue from here...

Logged

misterx

  • Aircrack-ng Author
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1844
  • Aircrack-ng Author
    • Aircrack-ng
Re: Installing Backports Wireless Drivers
« Reply #3 on: July 26, 2015, 04:14:40 pm »

Please learn to read error messages. You error is a missing firmware. You most likely installed the backports for nothing.

You have 2 occurrences of the following message:
Code: [Select]
[41731.112528] usb 2-2: ath9k_htc: Firmware - htc_9271.fw download failed
Logged

pedropt

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 73
Re: Installing Backports Wireless Drivers
« Reply #4 on: July 29, 2015, 12:03:57 am »

try to install that specific driver manually .
i found this on sourceforge :
https://sourceforge.net/projects/ath9k-htc/files/ath9k_htc-installer/

download the file and install it using this command on its directory :
Quote
dpkg -i ath9k_htc-installer_1-0-4.deb

i have no idea if it will work , i don't have that wifi pen model .
If it stays the same then try to find the original driver , compile it and install it .

look at this thread for that specific driver :
http://www.linuxquestions.org/questions/slackware-14/ar9271-driver-4175430121/
« Last Edit: July 29, 2015, 12:24:32 am by pedropt »
Logged

misterx

  • Aircrack-ng Author
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1844
  • Aircrack-ng Author
    • Aircrack-ng
Re: Installing Backports Wireless Drivers
« Reply #5 on: July 29, 2015, 04:09:26 am »

Don't install that, it's way older than the driver you currently have (2011). If you want latest and greatest, get the linux-backports and install them.
Logged

pedropt

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 73
Re: Installing Backports Wireless Drivers
« Reply #6 on: July 29, 2015, 05:16:31 pm »

current backports driver is not working on him , and that is the reason why i dropped the links for the old drivers for him to test .
Logged

Marcus Lee

  • Guest
Re: Installing Backports Wireless Drivers
« Reply #7 on: March 15, 2016, 12:08:32 pm »

Hi there I am using Kali Linux 2016.1 here and I got this error even after I installed all the needed linux headers, it mentioned about including a .config file, how do I write the .config file?

/--------------
| Your kernel headers are incomplete/not installed.
| Please install kernel headers, including a .config
| file or use the KLIB/KLIB_BUILD make variables to
| set the kernel to build against, e.g.
|   make KLIB=/lib/modules/3.1.7/
| to compile/install for the installed kernel 3.1.7
| (that isn't currently running.)
\--
Makefile:40: recipe for target 'modules' failed
make[1]: *** [modules] Error 1
Makefile:30: recipe for target 'default' failed
make: *** [default] Error 2
Logged

homeuser2

  • Guest
Re: Installing Backports Wireless Drivers
« Reply #8 on: March 30, 2016, 11:24:07 pm »

Running Ubuntu 4.2.0-27-generic

Followed the script below, only change was to the latest driver:

sudo apt-get update && apt-get upgrade -y
sudo apt-get install linux-headers-$(uname -r)
cd /usr/src/
sudo wget http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.16.2/backports-3.16.2-1.tar.xz
sudo tar xvfJ backports-3.16.2-1.tar.xz
cd backports-3.16.2-1
sudo make defconfig-wifi
sudo make
***sudo make install***
sudo update-initramfs -u
reboot

When running the make install I received “Can't read private key DEPMOD 4.2.0-27-generic
depmod will prefer updates/ over kernel/ -- OK!”  example below:

INSTALL /usr/src/backports-4.2.6-1/net/wireless/lib80211_crypt_wep.ko
Can't read private key
DEPMOD 4.2.0-27-generic
depmod will prefer updates/ over kernel/ -- OK!
Note:
You may or may not need to update your initramfs, you should if
any of the modules installed are part of your initramfs. To add
support for your distribution to do this automatically send a
patch against "update-initramfs.sh". If your distribution does not
require this send a patch with the '/usr/bin/lsb_release -i -s'
("Ubuntu") tag for your distribution to avoid this warning.

Your backported driver modules should be installed now.
Reboot.


I am very new to Linux so do not know if the is a over the top noobe question?  Or is backports only for Kali Linux?  If that is the case what is the best way to install a driver for RT3072?

Signed on as user homeuser clicked on forgot password, have not received email going on over 48 hours, just tried again.

Thanks in advance
Logged

Farbod

  • Guest
Re: Installing Backports Wireless Drivers
« Reply #9 on: July 23, 2016, 05:03:57 pm »

Hey there.
First, sorry to bring this up again.

I have the same exact error message as Marcus Lee, would someone help on this please?
I'm on Fedora 24, but I assume distro isn't that much related to error message.

Thanks.
Logged

Unimportant

  • Guest
Re: Installing Backports Wireless Drivers
« Reply #10 on: November 20, 2016, 11:56:23 pm »

Please learn to read error messages. You error is a missing firmware. You most likely installed the backports for nothing.

You have 2 occurrences of the following message:
Code: [Select]
[41731.112528] usb 2-2: ath9k_htc: Firmware - htc_9271.fw download failed

Maybe dont be a dick to the people who come here for help... makes me want to skip this site... obviously its gonna be the people who need to "learn" who are seeking help. Hope they dont run into an ass hole like you tho
Logged

zizon65

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: Installing Backports Wireless Drivers
« Reply #11 on: March 24, 2017, 03:16:05 pm »

Followed the script below, only change was to the latest driver:

sudo apt-get update && apt-get upgrade -y
sudo apt-get install linux-headers-$(uname -r)
cd /usr/src/
sudo wget http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.16.2/backports-3.16.2-1.tar.xz
sudo tar xvfJ backports-3.16.2-1.tar.xz
cd backports-3.16.2-1
sudo make defconfig-wifi.....
All went well till sudo make as after i tiped make enter, I got this:

root@kali:/usr/src/backports-4.2.6-1# make
make[5]: 'conf' is up to date.
boolean symbol HWMON tested for 'm'? test forced to 'n'
boolean symbol HWMON tested for 'm'? test forced to 'n'
#
# configuration written to .config
#
Building backport-include/backport/autoconf.h ... done.
  CC [M]  /usr/src/backports-4.2.6-1/compat/main.o
In file included from /usr/src/backports-4.2.6-1/backport-include/backport/backport.h:7:0,
                 from <command-line>:0:
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h: In function ‘__qrwlock_write_byte’:
/usr/src/backports-4.2.6-1/backport-include/linux/kconfig.h:25:28: error: implicit declaration of function ‘config_enabled’ [-Werror=implicit-function-declaration]
 #define IS_BUILTIN(option) config_enabled(option)
                            ^
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h:156:26: note: in expansion of macro ‘IS_BUILTIN’
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
                          ^~~~~~~~~~
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h:156:37: error: ‘CONFIG_CPU_BIG_ENDIAN’ undeclared (first use in this function)
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
                                     ^
/usr/src/backports-4.2.6-1/backport-include/linux/kconfig.h:25:43: note: in definition of macro ‘IS_BUILTIN’
 #define IS_BUILTIN(option) config_enabled(option)
                                           ^~~~~~
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h:156:37: note: each undeclared identifier is reported only once for each function it appears in
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
                                     ^
/usr/src/backports-4.2.6-1/backport-include/linux/kconfig.h:25:43: note: in definition of macro ‘IS_BUILTIN’
 #define IS_BUILTIN(option) config_enabled(option)
                                           ^~~~~~
cc1: some warnings being treated as errors
/usr/src/linux-headers-4.9.0-kali3-common/scripts/Makefile.build:298: recipe for target '/usr/src/backports-4.2.6-1/compat/main.o' failed
make[8]: *** [/usr/src/backports-4.2.6-1/compat/main.o] Error 1
/usr/src/linux-headers-4.9.0-kali3-common/scripts/Makefile.build:549: recipe for target '/usr/src/backports-4.2.6-1/compat' failed
make[7]: *** [/usr/src/backports-4.2.6-1/compat] Error 2
/usr/src/linux-headers-4.9.0-kali3-common/Makefile:1507: recipe for target '_module_/usr/src/backports-4.2.6-1' failed
make[6]: *** [_module_/usr/src/backports-4.2.6-1] Error 2
Makefile:150: recipe for target 'sub-make' failed
make[5]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[4]: *** [all] Error 2
Makefile.build:6: recipe for target 'modules' failed
make[3]: *** [modules] Error 2
Makefile.real:88: recipe for target 'modules' failed
make[2]: *** [modules] Error 2
Makefile:40: recipe for target 'modules' failed
make[1]: *** [modules] Error 2
Makefile:30: recipe for target 'default' failed
make: *** [default] Error 2
root@kali:/usr/src/backports-4.2.6-1# make install
  CC [M]  /usr/src/backports-4.2.6-1/compat/main.o
In file included from /usr/src/backports-4.2.6-1/backport-include/backport/backport.h:7:0,
                 from <command-line>:0:
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h: In function ‘__qrwlock_write_byte’:
/usr/src/backports-4.2.6-1/backport-include/linux/kconfig.h:25:28: error: implicit declaration of function ‘config_enabled’ [-Werror=implicit-function-declaration]
 #define IS_BUILTIN(option) config_enabled(option)
                            ^
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h:156:26: note: in expansion of macro ‘IS_BUILTIN’
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
                          ^~~~~~~~~~
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h:156:37: error: ‘CONFIG_CPU_BIG_ENDIAN’ undeclared (first use in this function)
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
                                     ^
/usr/src/backports-4.2.6-1/backport-include/linux/kconfig.h:25:43: note: in definition of macro ‘IS_BUILTIN’
 #define IS_BUILTIN(option) config_enabled(option)
                                           ^~~~~~
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h:156:37: note: each undeclared identifier is reported only once for each function it appears in
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
                                     ^
/usr/src/backports-4.2.6-1/backport-include/linux/kconfig.h:25:43: note: in definition of macro ‘IS_BUILTIN’
 #define IS_BUILTIN(option) config_enabled(option)
                                           ^~~~~~
cc1: some warnings being treated as errors
/usr/src/linux-headers-4.9.0-kali3-common/scripts/Makefile.build:298: recipe for target '/usr/src/backports-4.2.6-1/compat/main.o' failed
make[7]: *** [/usr/src/backports-4.2.6-1/compat/main.o] Error 1
/usr/src/linux-headers-4.9.0-kali3-common/scripts/Makefile.build:549: recipe for target '/usr/src/backports-4.2.6-1/compat' failed
make[6]: *** [/usr/src/backports-4.2.6-1/compat] Error 2
/usr/src/linux-headers-4.9.0-kali3-common/Makefile:1507: recipe for target '_module_/usr/src/backports-4.2.6-1' failed
make[5]: *** [_module_/usr/src/backports-4.2.6-1] Error 2
Makefile:150: recipe for target 'sub-make' failed
make[4]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[3]: *** [all] Error 2
Makefile.build:6: recipe for target 'modules' failed
make[2]: *** [modules] Error 2
Makefile.real:88: recipe for target 'modules' failed
make[1]: *** [modules] Error 2
Makefile:40: recipe for target 'install' failed
make: *** [install] Error 2
root@kali:/usr/src/backports-4.2.6-1#
any clue? I really need help please...
Logged

misterx

  • Aircrack-ng Author
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1844
  • Aircrack-ng Author
    • Aircrack-ng
Re: Installing Backports Wireless Drivers
« Reply #12 on: March 24, 2017, 03:46:23 pm »

You were downgrading the drivers. The backports version is related to the kernel version it is based on. So, in this case, you would have downgraded from 4.9 to 3.16.
Logged

zizon65

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: Installing Backports Wireless Drivers
« Reply #13 on: March 24, 2017, 07:00:16 pm »

You were downgrading the drivers. The backports version is related to the kernel version it is based on. So, in this case, you would have downgraded from 4.9 to 3.16.

Thanks for your reply Bro, and following what you've stated, i am going to download and install the 3.16 version and will let you know.
Again  thanks;
Logged

zizon65

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: Installing Backports Wireless Drivers
« Reply #14 on: March 24, 2017, 07:48:43 pm »

You were downgrading the drivers. The backports version is related to the kernel version it is based on. So, in this case, you would have downgraded from 4.9 to 3.16.

Thanks for your reply Bro, and following what you've stated, i am going to download and install the 3.16 version and will let you know.
Again  thanks;

I tried downgrading from 4.9 to 3.16, but did not succeed anymore. When I intered make defconfig-wifi
I got this: root@kali:/usr/src/backports-3.16.2-1# make defconfig-wifi
Generating local configuration database from kernel ...Kernel version parse failed!
Makefile:40: recipe for target 'defconfig-wifi' failed
make: *** [defconfig-wifi] Error 1
Thanks.
Logged
Pages: [1] 2 3   Go Up